Symptom
You have created a Credit Memo as a Follow-Up document of Customer Invoice and observed that the Credit Memo is not posted in accounting. Basically, there is no Journal Entry created.
Or
You see an unposted Credit Memo with error message: "Cannot post this document as tax amount in transaction currency ABC is 0." (ABC represents the currency type)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing workcenter.
- Click New Manual Invoice.
- Fill the relevant data and Release the invoice - AAA. (AAA represents the Invoice ID)
- Go to Invoice Documents view in the same workcenter.
- Select the Released invoice - AAA and click Follow-Up - Manual Credit Memo.
- Fill the relevant data and Release Credit Memo - BBB. (BBB represents the Credit Memo ID)
- Now, go to General Ledger work center.
- Click Journal Entries view and Search for Credit Memo - BBB.
- You cannot find the Journal Entry for Credit Memo.
OR
- Go to general ledger work center
- Source document and unposted list
- Search for relevant credit memo and error 'Cannot post this document as tax amount in transaction currency ABC is 0.' can be seen
Cause
There is a difference in amount between Credit Memo and Customer Invoice. For Example:
Customer Invoice - AAA Total Amount - 168,01
Credit Memo - BBB Total Amount - 168,00
When you create a Follow-Up document then the system calculates Tax Amount and Tax Base Amount. In this case, the Tax Amount is zero, but there is a small difference on Tax Base Amount. This leads to error in the backend and system do not create Journal Entry.
Resolution
Part A) Follow the below steps to clear the Customer Invoice and Credit Memo:
- Go to Customer Invoicing work center.
- Click New Credit Memo. (Not as a Follow-Up document using Customer Invoice-AAA)
- Fill the relevant data and Release the Credit Memo - CCC. (CCC represents the New Credit Memo ID)
- Go to Receivables workcenter.
- Click Customer Accounts view.
- Select Customer Account and click View.
- Select Customer Invoice - AAA and Credit Memo - CCC.
- Click Clear Manually.
- You have to Apply Discount and Select the Payment Difference Reason which is Not Tax Relevant[For example: 97 - Currency exchange differences].
- Click Clear.
Part B) You have to Cancel the Follow-Up Credit Memo.
- Go to Customer Invoicing Work center.
- Go to Invoice Documents view.
- Search for the Credit Memo - BBB.
- Click Cancel and Release the Cancellation Credit Memo DDD. (DDD represents the Cancellation Credit Memo ID)
- Go to the Document Flow of Cancellation Credit Memo DDD.
- Here, you can find the Process Communication Error icon on Original Credit Memo - BBB.
- You have to Report an Incident to clear the Process Communication Error with reference to the KBA.
- The Original Credit Memo BBB is stuck in the backend, so the system will not allow posting its Cancellation.
- SAP will Restart the XI Message for Original Credit Memo - BBB. This action will create Journal Entries for both Original and Cancelled Credit Memo.
Note: Customers should Report an Incident because SAP has to take action from backend. If the Process Communication Error is not actioned by SAP, then the financial reports will display inaccurate figures/amounts.
Keywords
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