SAP Knowledge Base Article - Public

3312969 - Custom communication scenarios: Allowed Scenarios instances - SAP S/4HANA Cloud Public Edition

Symptom

  • Create a custom communication scenario for Key User Extensibility/Developer Extensibility..
  • Edit a custom communication scenario for Key User Extensibility created before S/4HANA Cloud 2302 but not be allowed with errors "An Error occurred in communication Arrangement YY1_CA. Communication scenario already in use".

Environment

SAP S/4HANA Cloud Public Edition

SAP S/4HANA Cloud Public Edition  2302

Cause

Key User Extensibility

Predefined communication scenarios are available for different use cases, for example the integration for employee data. Decide which scenario is going to use be used to create a communication arrangement.

Create custom communication scenarios using the Custom Communication Scenarios app in Key User Extensibility is available

A communication arrangement can later be created using the Communication Arrangements app. A communication scenario bundles inbound and outbound communication design-time artifacts and is a basis for communication between systems. Each communication arrangement must be based on a communication scenario.

Developer Extensibility

A communication scenario, which is created in the development system using ABAP Development Tools and transported to other systems, is a design time description of how two communication partners communicate with each other. It consists of inbound and/or outbound services as well as supported authentication methods.

It provides technical information, such as the used inbound and outbound services and their service type, for example OData or SOAP, and the number of allowed communication arrangement instances. If the scenario exposes inbound services, it specifies the authorizations that are required to execute the services.

The following types of communication scenarios are available:
  • Managed by SAP, where SAP provides a ready-to-use communication scenario and communication arrangement is created and maintained.
  • Managed by customer, where a communication scenario is developed and communication arrangement is created and maintained.

Resolution

Key User Extensibility

As of S/4HANA Cloud Public Edition 2302, if an Outbound Service is not added to the Custom Communication Scenario, the custom communication scenario will be created with property Allowed Instances: One Instance per Scenario and Communication System

If an Outbound Service is added to the Custom Communication Scenario, then it will be created with property Allowed Instances: One Instance per Client.

The restriction to allow only one custom communication scenario per client was introduced with S/4HANA Cloud Public Edition 2302.

The custom communication scenarios that have been created before that release will have the type One Instance per Client automatically.

However, if no outbound service is used the type can be changed to One Instance per Scenario and Communication System.

If the type is to be changed, there are two possible workarounds:

  • Republishing the scenario.
  • Adding a dummy outbound service, removing it and saving it

In this case, the type will be changed to One Instance per Scenario and Communication System. This type will allow to create more than one communication arrangements per custom communication scenario.

Developer Extensibility

  • Allowed Scenarios instances: One instance per client

    Only one active communication arrangement can be maintained for the communication scenario in the system.

  • Allowed Scenarios instances: One instance per scenario & communication system

    Multiple active communication arrangements for one communication scenario for different communication systems in one system are enabled.

See Also

Key User Extensibility - Communication Management

Key User Extensibility - Custom Communication Scenarios

Key User Extensibility - Communication Arrangements

Fiori Apps Library - Custom Communication Scenarios

Fiori Apps Library - Communication Arrangements

Developer Extensibility - Communication Management

Developer Extensibility - Service Consumption via Communication Arrangements

Keywords

custom communication scenario, allowed Instances, One Instance per ClientOne Instance per Scenario and Communication System, key user extensibility, developer extensibility , KBA , BC-SRV-APS-COM , Maintain Communication System and Arrangement , Problem

Product

SAP S/4HANA Cloud 2302