Symptom
The onboarding email notifications are not being received by the responsible group participants although the email status shows that the email is sent to the users..
Environment
SAP SuccessFactors Onboarding
Cause
Some invalid email is maintained as receipient.
Resolution
- Go to Email Service >> Email Status, find the email not be received
- Click on Details and check if any invalid email is added as a receipient.
- Remove all invalid emails from the template.
Please find the below generic recipient pattern that will be discarded internally in the email infrastructure.
Regex (.*) meaning any characters, so any recipients starting with dummy@anydomain will be ignored along with the other recipients in the same message.
Similarly, any recipient for the @example.com domain will be discarded and so on. This is the generic list for all the DCs.
/^.*@example\.com$/ discard
/^.*@test\.com$/ discard
/^.*@.*\.test\.com$/ discard
/^.*noemail.*@.*$/ discard
/^.*test.*@.*$/ discard
*SF Email sent to end user who's email is XXX@sap.com recipients (SAP colleague)
In the past, we relayed emails with @sap.com recipients directly to the SAP mail gateway will be rejected by SAP mail gateway. However now no the rule is not valid anymore. Means in below scenarios, recpient email is XXX@sap.com can receive SF email as normal:
- recpient email is XXX@sap.com
- customer has enabled Single Sender.
- customer add new provisioner which will send email to the new provisioner; the provisioner is SAP colleague
So as of now, emails to @sap.com are being sent through the internet, to whatever is in the domain’s MX record like any other mail traffic.
See Also
2087890 - Top Reasons Why Email Notifications Are Not Sent or Received. Basic Troubleshooting - HXM Suite
Keywords
KBA , LOD-SF-OBX-EML , Notifications , Problem