Symptom
A data removal run remains with status In Process in the Data Protection and Privacy work center and cannot be deleted or set to status Obsolete.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open work center Data Protection and Privacy
- Open Common Tasks view
- Click Administer Data Removal Runs
- Switch to list of All Deletion Runs
- Select the relevant run ID
- Find the run has been running for some time
- Delete as well as Actions > Set to Obsolete is grayed out
- When checking the relevant Application Log, find no content in General/Settings/Results tabs
- Open work center Administration
- Open Background Jobs view
- Search for the relevant run job
- The job is not findable in Scheduled, Failed, Running Last Week or Running Job
Cause
- The issue might be cause by a backend inconsistency.
- The run in administrator work center has been processed and the business partner has been deleted.
- The status of the deletion is success, just the creation of the log remains in process.
Resolution
Forward to SAP Solution Support. If possible, SAP will set the deletion run to Obsolete, so that it will be possible to delete this run on customer side.
Keywords
stop, remove, removal, does not work, impossible, not possible, unable, not able , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem
Product
SAP Cloud for Customer core applications all versions