SAP Knowledge Base Article - Public

3314013 - User Account and Contact Details Are Not Visible in Customer Workcenter.

Symptom

User maintained the account and contact details however it is not visible in Customer workcenter.

Environment

SAP Business ByDesign

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers WorkCenter.
  2. Navigate to Accounts View.
  3. Search and open account ID to verify if details are maintained.
  4. Navigate to Contacts view.
  5. Select and open the Business Role ID of respective account.

Account and contact details maintained under Business Role ID is not visible in screen.

Cause

Read access "restricted" for Business Role ID.

Resolution

  1. Go to Administrator WorkCenter.
  2. Navigate to General Settings view.
  3. Under "Users" view choose " Business Role"
  4. Select and Open Business Role ID
  5. Choose "View All"
  6. Go to "Access Restriction" Tab. 

For Workcenter view Accounts and Contacts read access should be Unrestricted then user can see maintained details on screen.

Keywords

Read access,unrestricted, Account and contact details,maintained details not visible, Customer workcenter , KBA , maintained details not visible , customer workcenter , read access , unrestricted , account and contact details , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions