SAP Knowledge Base Article - Public

3314143 - Emergency Contact address information is blanked out when any field from the portlet is changed via Edit UI

Symptom

When the flag "Enable Centralized Services for Emergency Contact (Applicable for data imports from UI and API and saving changes on Editing UI)" is enabled in Company System and Logo Settings, once you change any field from the Emergency Contact details (relationship, e-mail, etc), the Address Information for the contact is blanked out.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

  • Go to Employee File > Emergency Contact portlet
  • When clicking “Details”, the Address information of the contact is there (city, state, zip code, etc)
  • Closing that and clicking on the pencil icon
  • Change any field - for example, "relationship", and click save
  • Now click in “Details” again > the Address information is blank

The behavior does not occur if the flag “Enable Centralized Services for Emergency Contact (Applicable for data imports from UI and API and saving changes on Editing UI) is disabled.

Cause

This is an expected behavior by design.

Resolution

When Centralized Services is enabled, change business key is considered as delete + insert. This means that old records will be deleted in order to insert a new record, that's why the address related data is reset. 

When Centralized Services is disabled, change business key is considered as an update, which means that old records will be updated and all other fields or child entity record fields won't be impacted - that's why the address record is maintained.

See Also

Centralized Services Support Emergency Contacts

Keywords

Centralized Services, Emergency Contact, address, blanked out, blank, deleted, address information, portlet, edit, pencil icon, Edit UI , KBA , LOD-SF-EC-PER-ECO , Emergency Contact Details , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions