Symptom
When creating an email, when you try to add an email template, you notice that the templates are available only in a single language e.g. English, and you expect it should be available in multiple languages.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Navigate to Cases work center.
- Open any case.
- Click on the Send Mail icon.
- On the editor, click Add Template button.
- See in the pop-up, the template is available only in a single language e.g. English.
Cause
This is the system designed behavior when only a single template file (.HTML) has been uploaded in the system.
Resolution
To have the template available in multiple languages, you need to ensure that different .HTML files of the template, for multiple languages, are uploaded in the system, following the steps below:
- Navigate to your user profile on the top-right corner of your screen.
- Click Settings.
- Navigate to All Settings tab.
- Click Templates, under Email.
- Select your template and click Edit.
- Upload additional .HTML files, one for each language you would like to have the template available.
Once you upload the template .HTML file, you can define which language the file will use in the Attachments tab.
Keywords
Template, Email, E-mail, File, HTML, Language, Available, Email Editor, Case, Case Management, Add Templates, Add, Languages, Upload, SAP Service Cloud Version 2, , KBA , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , How To