Symptom
User trying to generate PDF for all customer account statements that are there in the periodic task view.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Receivables Work center
- Navigate Periodic Tasks View
- Go to Customer Account Statement
- Choose Account Statement Run ID
- Click View Report Run Results
- Navigate to Attachments
When Opening the attachment screen shows error" Service Cannot Be Reached"
Cause
Issue is due to "cache" in periodic task attachment tab (represents Output History tab) which has huge documents.
When the attachment tab is loaded the documents that are there in the top/beginning of the attachment tab get loaded automatically and the screen is loaded and stored in browser cache.
However the documents which are at the bottom/end are neither loaded nor stored in cache and when user is clicking on the document screen throws error.
Resolution
To view the PDF, user has to select the entry in Attachment tab first so that information of the document gets loaded and then choose the document link so that PDF is displayed.
Keywords
periodic task attachment tab, Customer Account Statements output not available, unable to generate PDF , KBA , unable to generate pdf , periodic task attachment tab , AP-RC-OUT , Output Management , Problem