SAP Knowledge Base Article - Public

3315160 - Pro Forma Invoice Displays Different Value than Customer Invoice

Symptom

You find that Pro Forma Invoice displays different value than customer invoice if you change the price list.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to Sales Orders Work Center - Sales Orders View
  2. Select Sales Order ABC (ABC represents your sales order ID)
  3. The List Price is 3163 EUR
  4. Then change the price in Price List to 2000 EUR
  5. Click Pro Forma Invoice button for Sales Order ABC
  6. You can see the Price changes to 2000 EUR
  7. Create Pro Forma Invoice for relevant Outbound Delivery EFG (EFG represents Outbound Delivery ID)
  8. You can see List Price is still 3163 EUR

Cause

There are pricing relevant extension scenarios are present in the system which are causing the retrigger of price and hence, new list price is being considered during generation of Pro Forma Invoice.

You can see extension fields which are pricing relevant and have extension scenario of Sales Order -> Invoice Request.

Whereas in outbound delivery-> Pro Forma invoice creation, extension scenarios are not scoped which is why you are able to see the old prices from Sales Order.

If the value in the extension field is not filled under sales order and even though they are pricing relevant and values are flowing from sales order to invoice request, pricing recalculation will not be triggered in such cases.

Resolution

This is the expected behaviour.

Keywords

Pro Forma Invoice, customer invoice, Sales Order, Outbound Delivery, Price List, extension fields , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions