Symptom
- You're trying to create a new Business User Group with Maintain Business User Group app but you are receiving the error message "No authorization to create user group ZCB".
- You have the Business Catalog SAP_CORE_BC_IAM_GRP_PC assigned to your user.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to Maintain Business User Groups app
- Click on "Create" button
- Choose the name of your Business User Group
- Click on "Create" again
- Error message is triggered
Cause
The Business Role containing the authorizations for the application is restricted with Display Only access. You can find this information in the Business Role details on the upper side of the page in "Write Access" field. The business role will be maintained with "Write Access: No Access".
Resolution
In order to provide edit access to the user you need to maintain the Business Role changing the "Write Access" restriction to "Unrestricted". You can do this by following the steps below:
- Open the Business Role in edit mode
- Click on "Maintain Restrictions" button
- In the "Write, read and value help" tab, click on the dropdown
- Select "Unrestricted"
- Save/publish the role
Please note that this restriction will apply to ALL Business Users that are assigned to this Business Role and to ALL Business Catalogs.
If you do not want to apply this unrestricted access to all users and catalogs inside this role, I recommend you to create a new Business Role with access to this app with "Unrestricted" restriction.
See Also
For more information, please check SAP Help Portal | How to Define Authorizations Based on Restrictions.
Keywords
create, Business User Group, Maintain Business User Groups. app, application, error message, no authorization to create user group ZCB, business catalog, SAP_CORE_BC_IAM_GRP_PC, assigned, restriction, restricted, write access, no access, authorization , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem