SAP Knowledge Base Article - Public

3315548 - Error "You either do not have the required authorization or there is no data to be displayed" in Customer Data Browser - SAP S/4HANA Public Cloud

Symptom

Unable to view data in the application 'Customer Data Browser' due to the following errors:

  • "You either do not have the required authorization or there is no data to be displayed".
  • "No authorization to view object data".

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the application 'Customer Data Browser'.
  2. Select any CDS View or Table to display data.
  3. Error will display: "You either do not have the required authorization or there is no data to be displayed" or "No authorization to view object data".

Cause

  • To view the data using the Customer Data Browser application the user should have maintained the role authorization in the 'Maintain Business Role' application as described in the document: Data Visibility Based on Restrictions | SAP Help Portal.
  • The Access Categories of the relevant business role containing catalog 'SAP_CORE_BC_CDB_PC' has been set to 'Unrestricted'.
  • The affected business role typically uses the business role template SAP_BR_ADMINISTRATOR_DANA.
  • The object records should be maintained as either 'OV' or 'AC'. It is not permissible to maintain them as 'Unrestricted'.
  • In cases to provide privileged access, choose OV – Records with privileged access. In cases when choosing AC – Records without privileged access, please ensure to provide the necessary authorizations for the end user for previewing the data.

Resolution

  1. Open the app 'Maintain Business Roles'.
  2. Edit the business role which contains the business catalog: SAP_CORE_BC_CDB_PC.
  3. Set the Access Categories to the following:
    1. 'Write, Read, Value Help': No Access
    2. 'Read, Value Help': Restricted
    3. 'Value Help': Unrestricted
  4. Click "Maintain Restrictions" and apply the following restriction values for "Customer Data Browser Object Group / Object Name / Object Field / Object Row":

    Object Group: * (Unrestricted)
    Object Name: * (Unrestricted)
    Object Fields: General fields (GE) <or> Sensitive personal fields (SP) <or> Both
    Object Records: 'OV' or 'AC'

    **Please note that if all your access categories are set to "Unrestricted" you'll not be able to set the object records.

Please also note the following cases to avoid the possible authorization issue:

  1. Assign the business role with catalog "SAP_CORE_BC_CDB_PC" to a business user who does not have the SAP_BR_ADMINISTRATOR role.
  2. Make sure that the user only has one role with the catalog "SAP_CORE_BC_CDB_PC". Multiple assigned roles with catalog "SAP_CORE_BC_CDB_PC" may cause authorization issues when accessing the Customer Data Browser app.

See Also

Keywords

Customer Data Browser, SAP_CORE_BC_CDB_PC, You either do not have the required authorization or there is no data to be displayed, No permission to display the object data, no authorization, display data, tables, error, authorization, Unrestricted, No Access, Access Categories, Maintain Restrictions, business role, business catalog, SAP_BR_ADMINISTRATOR_DANA, OV, AC, standard, view, cds, tables, cds view, administrator, data , KBA , BC-SRV-APS-CDB , Customer Data Browser , Problem

Product

SAP S/4HANA Cloud Public Edition all versions