Symptom
You receive an error "Only HTML documents are supported. File has not been replaced." when you are trying to replace an existing Service template with a new template.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service Work Center
- Go to the Templates view
- Search and open the template needed to be replaced
- Click on edit
- Upload the new template file
Error message raised: Only HTML documents are supported. File has not been replaced
Cause
The file you are trying to upload is in unsupported format or has an incorrect extension (like ".htm").
As per the current standard behavior only HTML documents with ".html" extension are supported for Templates.
Resolution
Please create a ".HTML" template and then upload it again to resolve the issue.
See Also
2665839 - You Are Not Able To Use Document-Based E-mail Template When Processing A Ticket
Keywords
Error , Template , HTML template , Replace , Service Template , Not Replaced , Edit template , KBA , LOD-CRM-SC-TMP , Template , LOD-CRM-SRP , Service Request Processing , How To