Symptom
The language (standard or custom) selected from Additional Communication Languages, is not visible under Logon screen.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Business Configuration Workcenter.
- Go to Implementation Projects view.
- Click on the project and click Open Activity List.
- Search for and double-click activity "Additional Communication Languages".
- Select the desired Language by clicking on the respective Checkbox.
- Save and Close.
- When trying to login again, the language is not visible as "Language (Customer Language)".
Cause
The logon language extension only appears after a text pool for that language has been created and filled. When creating a Language Adaptation with target language as the language selected from the Additional Communication Languages, the additional language appears on the logon screen with an extension "Language (Customer Language)".
Resolution
For example, a Language Adaptation needs to be created with source language (for example French) to target language (for example, custom language Canadian French), and then add/create a translation text inside UI Texts tab for it. Then the language (in this example, "Canandian French (Customer Language)" will be shown in logon dropdown menu.
For that, please follow:
- Go to Administrator > General Settings.
- Open Language Adaptation.
- Create a new LA with the source and target languages.
- Go to UI Texts tab and add the translation for the fields in the target language.
- Save.
- Logon again, the "Language (Customer Language)" will be displayed.
Keywords
display, displays, show, invisible, unavailable, customized, Arabic, Bulgarian, Czech, Danish, German, English, Spanish, Finnish, Greek, Hebrew, Croatian, Hungarian, Italian, Korean, Japanese, Dutch, Norwegian, Polish, Portuguese, Romanian, Russian, Serbian, Slovak, Slovenian, Swedish, Thai, Turkish, Ukranian, Vietnamese, Simplified Chinese, Traditional Chinese , KBA , LOD-LE-RC-GEN-CDD , Central DDIC , AP-RC-TXA , C4C Text Adaptation , LOD-CRM-OPP , Opportunity Management , LOD-CRM-TRL , Translation , How To