Symptom
What is the Datasource for the fields Top Level Account ID and Account Hierarchy
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Account Management WorkCenter
- Navigate to Accounts View
- Search and select any account
- In general tab under Details these fields are available
Cause
These are Standard Fields and not available on any Data Sources
Resolution
- Business Object CUSTOMER has association to business object BUSINESS_PARTNER_HIERARCHY to identify the hierarchy group to which the instance of CUSTOMER (Account) is assigned to.
- On the UI additional logic is applied to determine the TopLevel Group of the hierarchy and the customer/account and instance assigned to this one. This is then displayed on the UI.
- There is not "the" field/element on the account/customer object which matches this information. Therefore, it is not available on any existing data sources. If you want to "see" that information on a data source, they need to rebuild that via implementation for a data source (if that is possible in PDI).
Keywords
Data Source , Fields, Account Hierarchy, Top Level Account ID , KBA , account hierarchy , top level account id , data source of field , SRD-CRM-ACC , Account Management , Problem
Product
SAP Business ByDesign all versions