SAP Knowledge Base Article - Public

3317508 - When Performing Migration of Product Categories Facing Error "Service call failed; Report an incident"

Symptom

When performing Migration of Product Categories system throws the error "Service call failed; Report an incident"

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Business Configuration Work Centre
  2. Select the Activities Menu
  3. Search for "Product Category Hierarchy"
  4. Click Execute Migration
  5. Execute Migration Step by Step
  6. Facing Error- Service call failed; Report an incident

Cause

The issue is occurring when you maintain multiple languages for a same product category ID

Resolution

Adding multiple entries in the migration template for the same product category and different languages from migration template is not supported.

This would be a new Requirement.

Workaround:

  • You can use an inbound web service to update the values from the below help document

https://help.sap.com/doc/a2b4c7ef61d64397b2b1d052082a8a08/2302/en-US/PSM_ISI_R_II_QUERY_PCH_IN.html

Here is a sample:

<ProductCategoryHierarchy>

<UUID>XXXXX</UUID>

<ID>ABCDF</ID>

<Description>

<Description languageCode="EN">Base</Description>

</Description>

<ProductCategoryHierarchyUsageCode>1</ProductCategoryHierarchyUsageCode>

NOTE:

XXXXX - Refers to UUID

ABCDF - Refers to Product Category ID


  • You can update the languages in the User Interface

Keywords

Migration Of Product Categories, Migration, adding multiple languages , KBA , AP-PRD-MIG , Product Data Migration and Replication , Problem

Product

SAP Business ByDesign all versions