SAP Knowledge Base Article - Public

3317570 - Advanced filters not showing results in executive review - Compensation

Symptom

No results are showing when applying advanced filters in executive review.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Compensation

Reproducing the Issue

  1. Open the template in Executive Review
  2. Create a filter and choose two options for the same field
  3. Save and Apply -> no results

Cause

When the condition "Is Equal To" is selected, system will search for users that match all those results. So in this case, system is searching for an employee which Job Title field is both Account Executive and Consulting/Analyst, which there are no results.

Resolution

To get the expected results, the "In" condition needs to be used. That condition works like "or" condition, so it will pull employees that have either Account Executive or Consulting/Analyst in their Job Title field.

Keywords

executive, review, view, advanced, filters, result, not, working, display, employees, users, in, equals, to , KBA , LOD-SF-CMP-EXR , Executive Review , Problem

Product

SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM Suite all versions