SAP Knowledge Base Article - Public

3318829 - Information mismatch between SF and C4C, AskHR , ECSC

Symptom

Errors:

  1. "User does not exist" in system error when accessing AskHR
  2. Your User profile is not configured, contact your system administrator.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
    • Employee Central
      • Ask HR - Employee Central Service Center (ECSC)

Reproducing the Issue

  1. Login in to SFSF Employee Central
  2. Open AskHR
  3. Error will prompt out.

Cause

One among many causes for this error is "User information mismatch between SF and C4C".

Resolution

Here you will find what all information should be same in SF and C4C.

First, please check If they User has Employee Central or not. For AskHR application to work, user should be an Employee Central user.

Then, please check below field information in C4C, If they match with SF

  • Person ID (Person ID External) in SF needs to match with employee ID in C4C system. Ensure that the Person ID is numeric. 
    Here Person ID external should be numeric, if its string(eg: email address), it will not replicate to C4C system and you will face an error.
  • First Name
  • Last Name

To configure user in C4C, below information are necessary,

  • Replicate the following Employee Central master data to your SAP Cloud for Customer system.
    • Personal details like first-name, last-name, gender, form of address.
    • Business email (required used as key identifier to fetch employees ticket information).
    • Business address & phone -> Workplace address in SAP Cloud for Customer.
    • Job information used to calculate the employee’s validity.

 

See Also

Configuring SAP Cloud for Customer | SAP Help Portal

Replicate Employee Data | SAP Help Portal

For other resolution steps for mentioned error, refer: 3145739 - AskHR Error "Your User profile is not configured, contact your system administrator." - SAP ONE Support Launchpad 

Keywords

information mismatch between SF and C4C, Your User profile is not configured, User does not exist, employees, AskHR, ECSC, Employee Central, Services Center, Employee Central Services Center, User, contact your system administrator, Employee Details, ASK HR, ECSC, Service Center, SF, C4C, Person ID, AskHR  , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP SuccessFactors HXM Suite 2305