Symptom
- Occasionally users may be unable to load an attachment included in an e-mail
- Instead of the actual attachment, there is a text file containing information such as:
- Following attachments were removed while creating the E-Mail Activity:Attachment Name: "xyz.xxx".
- Error: "Upload of MIME type application/others not permitted".
- The message could also be related to some else like Error: "Upload of MIME type application/application/x-pdf".
Environment
- SAP Cloud for Customer
- SAP Cloud for Sales
Reproducing the Issue
- Go to Service
- Tickets, and open the offending ticket
- Navigate to Overview, Timeline
* The message can also be observed under Administrator -> Web Service Message Monitoring
Cause
- Attachment blocked for security reasons
- The attachment could be harmful and contain potential threats to the system
Resolution
- Go to the Business Configuration Work Center.
- Select Overview and click Go to populate the Activities.
- Select Allowed MIME Types activity.
- Click Change Immediately.
- Make the changes depending on the message received:
- For example, if the error is related to "application/others", and the entry does not exist, then
- Click Add Row and enter new Zcode, MIME Type Code which starts with Z and set MIME Type as "application/**. Like application/others
- Activate this MIME Type Code by allowing the checkboxes for Allowed, Compressed.
- If the entry exits, then ensure the MIME Type Code is allowed by enabling the checkboxes for Allowed, Compressed.
See Also
2774580 - Error "Upload of MIME type application/octet-stream not permitted" when uploading Emails with attachments
Keywords
MIME, Blocked, Removed, Attachment, E-mail, Ticket, application/octet-stream, "MIME" "application/" , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , Problem
Product
SAP Cloud for Customer core applications 2302