Symptom
Error when running UPSERT through Integration Center in the Job Requisition entity:
"JobRequisition: UPSERT failed for the row with key: . Reason: templateId required, . The row will not be processed for subsequent entities."
Environment
SAP SuccessFactors Recruiting Management
Cause
This happens when the CSV file contains the column isDraft and the value associated with the column is wrongly configured in the CSV file. E.g.: the value is TRUE, or FALSE, or True, or False.
Resolution
The value for isDraft is case sensitive. As explained on the KBA 2771951 - How to update Job Requisition fields using Integration Center - Recruiting Management, the value for isDraft must be "true" or "false", all in lower case letters.
This often happens when using Excel, so it's advised to use another software to validate the values or to confirm that the formatting of the entry is retained in the spreadsheet prior to uploading it to the integration.
See Also
Keywords
job, requisition, template, templateId, ID, upsert, update, integration, center, centre, error. , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem