Symptom
When a field set to required does not contain any data, quote actions are available and not throwing any error.
Environment
SAP SALES CLOUD CPQ
Cause
Field not set as required in "Required Fields By Workflow Action".
Resolution
Field needs to be set as required in the workflow action, this can be done considering below steps:
- Enter in Setup;
- Under Workflow/Approval section, enter in "Required Fields By Workflow Action";
- Select the desired field as required based on the quote status.
See Also
Required fields by workflow action - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/4ee7e26e660943a088e4e3999c6df6f8.html?version=latest
Keywords
Workflow, Quote Field, Required, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ 2023