SAP Knowledge Base Article - Public

3321569 - [Onboarding] How to Remove External Users after Onboarding is Disabled

Symptom

Onboarding was disabled from the instance. How to purge remaining onboardees that were left over?

Environment

  • SAP SuccessFactors Onboarding
  • SAP SuccessFactors Platform

Reproducing the Issue

  1. Onboarding was disabled from the instance
  2. Now we have active ("e") and inactive ("d") external users left in the system
  3. Unable to purge because as onboardees, they do not fit into target population

Cause

  • Data issue
  • Here we can’t change the user status to "d" (inactive external) and purge since they will no longer own the target population for purging

Resolution

  1. We have to apply a workaround where we are changing the user status to ‘f’ i.e. inactive internal user
  2. Customers and Partners, please raise a request to Support Team
  3. Support team, please see internal note with the Script request for Operations team to be raised
  4. Customers, Partners, post the user status change, you can proceed with Purge Inactive user data purge

See Also

KBA 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users 

Keywords

Onboarding, Disabled, Inactive, External user, Data, Purge , KBA , LOD-SF-OBX-ADM , Admin UI , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors HXM Core 2111 ; SAP SuccessFactors Onboarding ; SAP SuccessFactors platform 2211