Symptom
When running the checks for Job Profile Builder application in Admin Center > Check Tool, issue(s) for the check "DuplicateJDMIdInJdmJpbMapping" can be found.
Environment
SAP SuccessFactors Job Profile Builder
Cause
- A translation is not populated for English US
- Duplicate records have the same JDM reference ID
Resolution
A translation is not populated for English US
By default, the system uses the "English US (en_US)" locale as reference, and Families and Roles may have been created using another locale (e.g. English UK en_UK). JDM does not have locales so when Families & Roles are created in JDM, the locale information used in the instance when data is created (instance default language) is not stored. Since the primary locale information is not saved in JDM, the system migrates the data to JPB in English US locale by default. You can add translations for the English US locale:
- Log in to SuccessFactors
- Follow the steps in Implementing and Managing Job Profile Builder - Exporting Your Job Profile Data Using Manage Job Profile Content Import/Export and select different family entities
- Navigate to Admin Center > Scheduled Job Manager
- Locate the MDF Data Export job and select View Details
- Click on Download Status to download the file
- Locate the name.en_US column
- Populate translation values > Save
- Follow the steps in Implementing and Managing Job Profile Builder - Importing New Job Profile Content Using Manage Job Profile Content Import/Export to import the file
Duplicate records have the same JDM reference ID
During data migration, competencies from Job Description Manager are created in the Center of Capabilities. When a competency is created in the Center of Capabilities with the same Name, Library and Category, but with a different group Group, the competency points to the same Job Description Manager reference in the mapping. In Job Profile Builder, they are separate records. You can manually deleted the duplicated competencies/behaviors using one of the following options:
Center of Capabilities
- Log in to SuccessFactors
- Navigate to Admin Center > Manage Center of Capabilities
- Select Competencies
- In the Search field, enter the name of the competency
- Check the box for the duplicated competency and select Delete
Import
- Log into SuccessFactors
- Follow the steps in Implementing and Managing Job Profile Builder - Exporting Your Job Profile Data Using Manage Job Profile Content Import/Export and for Competency
- Use the DELETE operator for any duplicate competencies
- Follow the steps in Implementing and Managing Job Profile Builder - Importing New Job Profile Content Using Manage Job Profile Content Import/Export to import the file
Still Need Help?
If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.
Keywords
JDM, JPB, migration, competency, competencies, Job Profile Builder, Job Description Manager, Check Tool, fail, fails, failed, failure, failures, DuplicateJDMIdInJdmJpbMapping, competencies, competency, Name, Library, Category, Group, Mapping of entity from Job Description Manager to Job Profile Builder , KBA , LOD-SF-TIH-JPB-MIG , Migration to Job Profile Builder , LOD-SF-TIH-JDM , Job Description Manager , Problem