SAP Knowledge Base Article - Public

3321738 - Error with Duplicate Job Description Manager reference in the mapping entity. (Check ID: DuplicateJDMIdInJdmJpbMapping) - Job Profile Builder

Symptom

When running the checks for Job Profile Builder application in Admin Center > Check Tool, issue(s) for the check "DuplicateJDMIdInJdmJpbMapping" can be found.

Environment

SAP SuccessFactors Job Profile Builder

Cause

  • A translation is not populated for English US
  • Duplicate records have the same JDM reference ID

Resolution

A translation is not populated for English US

By default, the system uses the "English US (en_US)" locale as reference, and Families and Roles may have been created using another locale (e.g. English UK en_UK). JDM does not have locales so when Families & Roles are created in JDM, the locale information used in the instance when data is created (instance default language) is not stored. Since the primary locale information is not saved in JDM, the system migrates the data to JPB in English US locale by default. You can add translations for the English US locale:

  1. Log in to SuccessFactors
  2. Follow the steps in Implementing and Managing Job Profile Builder - Exporting Your Job Profile Data Using Manage Job Profile Content Import/Export and select different family entities
  3. Navigate to Admin Center > Scheduled Job Manager
  4. Locate the MDF Data Export job and select View Details
  5. Click on Download Status to download the file
  6. Locate the name.en_US column
  7. Populate translation values > Save
  8. Follow the steps in Implementing and Managing Job Profile Builder - Importing New Job Profile Content Using Manage Job Profile Content Import/Export to import the file

Duplicate records have the same JDM reference ID

During data migration, competencies from Job Description Manager are created in the Center of Capabilities. When a competency is created in the Center of Capabilities with the same Name, Library and Category, but with a different group Group, the competency points to the same Job Description Manager reference in the mapping. In Job Profile Builder, they are separate records. You can manually deleted the duplicated competencies/behaviors using one of the following options:

Note, prior to deleting of duplicate competencies:

  • Check the for JDM ID Manage Data/search the competencies by name
  • Search for the Competencies by name in CofC
To correct the error, 2 possible means exist to verify which of the duplicate competencies should be removed:
  • First, it is usually the Competency with the last/more recent modify date which can be deleted
  • For Partners/Support, it can be verified via Provisioning:
    • Find the Competencies by Name in CofC, which have been flagged in the check tool error
    • Using the External Code and Competency ID from here, check Provisioning.
    • Here in Provisioning, there should be a Competency which has an ID which matches the Competency ID, and a GUID which matches the External Code, taken from CofC
    • The other competency which has a different GUID/External Code is the one which should be removed.

Center of Capabilities

  1. Log in to SuccessFactors
  2. Navigate to Admin Center > Manage Center of Capabilities
  3. Select Competencies
  4. In the Search field, enter the name of the competency
  5. Check the box for the duplicated competency and select Delete

Import

  1. Log into SuccessFactors
  2. Follow the steps in Implementing and Managing Job Profile Builder - Exporting Your Job Profile Data Using Manage Job Profile Content Import/Export and for Competency
  3. Use the DELETE operator for any duplicate competencies
  4. Follow the steps in Implementing and Managing Job Profile Builder - Importing New Job Profile Content Using Manage Job Profile Content Import/Export to import the file

Still Need Help?

If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.

For Partners:

Should you need further assistance, you may use the following resources:
Getting Help with Configuration and Best Practices - SAP Community

Implementation Design Principles | SAP SuccessFactors | SAP Community 

Keywords

JDM, JPB, migration, competency, competencies, Job Profile Builder, Job Description Manager, Check Tool, fail, fails, failed, failure, failures, DuplicateJDMIdInJdmJpbMapping, competencies, competency, Name, Library, Category, Group, Mapping of entity from Job Description Manager to Job Profile Builder , KBA , LOD-SF-TIH-JPB-MIG , Migration to Job Profile Builder , LOD-SF-TIH-JDM , Job Description Manager , Problem

Product

SAP SuccessFactors HCM Suite all versions