Symptom
When attempting to create a new service contract, the Select Transaction Type dialog appears, but no values are available for selection. This prevents the user from proceeding with contract creation.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
1. Open the Manage Service Contracts app (App ID: F3763).
2. Click Create.
3. A pop-up Select Transaction Type is displayed, but there's no transaction type values are displayed, and contract creation cannot continue
Cause
The issue is due to insufficient authorization in the assigned Customer Service Manager role.
Resolution
To resolve this:
- Open the Maintain Business Roles app.
- Locate the Customer Service Manager role (CUSTOMER_SRVC_MGR).
- Set Write Access to Unrestricted for this role.
This change will allow the system to display transaction types during contract creation.
Keywords
SAP S/4HANA Cloud Public Edition, Public Cloud, Service contract, SC1, F3763, transaction type, pop-up, popup, Select Transaction Type, no values, no access, Customer Service Manager, CUSTOMER_SRVC_MGR, authorization, write access, restricted, create contract, SAP S/4HANA Cloud, CRM , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , How To
Product
Attachments
img2.png |
img3.png |