Symptom
You expected that an error message would be triggered when entering wrong contract's item ID in Purchase Request, however, it doesn't happen.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Purchase Requests and Orders work center.
- Go to New Purchase Request Common Task view.
- Click in View All button.
- Navigate to Items tab.
- Enter in item product ABC (ABC is the product's ID).
- Go to Source of Supply subtab.
- Enter contract DEF (DEF is the contract's ID) or the system will enter a contract ID automatically.
- In contract item field, enter GHI (GHI is a random number).
System accepts item ID GHI. System should not have accepted ID GHI.
Cause
This scenario is a known issue. Based on priority, the development team will implement a fix in a future release.
Resolution
You are still able to change the Contract Item ID in the follow-up Purchase Order, but still, no error message is triggered during the process. However, once the Purchase Order is finished, the information cannot be corrected anymore.
If you face this issue and cannot change the ID from your side, please open an incident so SAP development team can perform the correction.
Keywords
Contract; Purchase Order; Purchase Request; Product , KBA , SRD-SRM-PRO , Purchase Requests and Orders , Known Error