Symptom
You find the customer invoice ABC is not available in the data source CRMCIVIB.
(ABC represents the customer invoice ID.)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics - Data Sources view.
- Open the data source CRMCIVIB (Customer Invoice Item), click Preview.
- Open the value help of selection field 'Invoice', you find the customer invoice ABC is not available in the list.
- Go to Customer Invoicing - Invoice Documents view.
- Search ABC, you can find this invoice is existed and with status Released.
Cause
The data source will only return invoice documents that are consistent. Invoice ABC is not consistent, and you can check this when you perform a check on the invoice on the UI.
Resolution
It is the current system design.
Keywords
CRMCIVIB; Customer Invoice Item data source; invoice missing. , KBA , SRD-CRM-INV , Customer Invoicing , Problem
Product
SAP Business ByDesign all versions