SAP Knowledge Base Article - Public

3323872 - SAP Analytics Cloud User cannot be activated/reactivated programmatically via the SCIM API

Symptom

There is an 'active' boolean property in the response schema of the users endpoint. This cannot be changed from true to false as a way to programmatically revoke the users license.

Environment

SAP Analytics Cloud 2023.8.0

Postman

Reproducing the Issue

  1. Create a POST request to the token URL and retrieve the access token property.
  2. Create a GET request to <SAC_Tenant>/api/v1/scim/Users and include the following headers: Authorization - Bearer <access_token>, x-sap-sac-custom-auth - true, x-csrf-token - fetch
  3. Create a PUT request to <SAC_Tenant>/api/v1/scim/Users/ID and include the following headers: Authorization - Bearer <access_token>, x-sap-sac-custom-auth - true, x-csrf-token - <string> (retrieved from previous GET request)
  4. Include the desired schema and change the active property from true to false.
  5. Observe that the user active flag is still set to true and has not been modified.

Cause

This particular property was never intended for programmatic use cases and was used at the customers own risk. The active property is available in the response schema and not the request schema and any attributes of the data model that are present in the response and not the request are auto populated and not intended to be modified by the API client.

Resolution

Logon to the SAC tenant and navigate to the users page. There will be an option in Q2 release that enabled you to deactivate the user via the user interface.
This feature enhancement is described in the following blog post - https://blogs.sap.com/2023/04/12/sap-analytics-cloud-activate-deactivate/

See Also

2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?

Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!

2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?

SAP Analytics Cloud > Learning > Guided Playlists

SAP Analytics Cloud > Learning > Guided Playlists > Getting Support

Need More Help? Contact Support or visit the solution finder today!

Your feedback is important to help us improve our knowledge base.

Keywords

2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively? Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge! 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud? SAP Analytics Cloud > Learning > Guided Playlists SAP Analytics Cloud > Learning > Guided Playlists > Getting Support Need More Help? Contact Support or visit the solution finder today! Your feedback is important to help us improve our knowledge base. , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0