Symptom
After creating a Service Contract, it is noted that the existing Payment methods are not being copied into the Service Contract from the respective Business Partner.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Open the Manage Business Partner/Maintain Business Partner App.
- Set the value for the dropdown "Display in BP Role" as FLCU00 Customer (Fin. Accounting).
- Click the Company Code button.
- Navigate to the Customer: Payment Transaction Tab.
- Within "Payment Data" set a value for Terms of Payment.
- Go to the Manage Service Contracts App.
- Create a Service Contract.
- Associate the contract with the Business Partner observed through steps 1 - 5.
- Navigate to the Billing tab within the service contract.
- Under Payment methods the value is empty.
The expectancy is that the value maintained in the Payment methods for the Business Partner should be automatically copied over to the Service Contract.
Cause
This is expected system behaviour.
Resolution
The automatic copying/determination of the payment methods maintained within Business Partner company code related data is not copied over to the Service Contract.
Keywords
service contract, service, sd, sales, contract, bp, business partner, s/4hana cloud, s/4hc , s4hc, service, business, partner , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem