Symptom
A custom Country/Region-Specific enabled field is not appearing for selection in business rules.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Configure a Country/Region-Specific field in any country in jobInfo, for example
- Create a rule based on Job Information or Job Information Model
- Try to find the custom field in the rule expressions
- See that the field is not findable.
Cause
The custom field is also configured in the global element, jobInfo. This would also be applicable for rules based on Compensation Information, where the field is configured in global compInfo.
Resolution
When a custom field is configured in the global HRIS Element, this configuration will take precedence over the Country/Region-Specific configuration, and the CSF field will not be visible for selection in the rule or in the role-based permissions. In the Employee Profile, the global HRIS Field will be visible, but with the CSF label for employees on that country.
For example:
- custom-string1 is configured in jobInfo with label "Custom Field"
- Same custom-string1 is configured in jobInfo_DEU with label "German Field"
- For employees from other countries, the field will appear in the profile as "Custom Field"
- For German employees, the field will appear in the profile as "German Field"
- In the Business Rule configuration or in Role-Based Permissions, the field will appear as "Custom Field".
See Also
Keywords
custom field, CSF, Country Region Specific Field, jobInfo, compInfo, job information rule, CSF field, custom CSF, RBP, employee profile , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-CMP-RUL , Business Rules , Problem