SAP Knowledge Base Article - Public

3325113 - Continuous Feedback Request status ID field not showing the value for some users in Report Stories even these users has received a feedback

Symptom

Continuous Feedback as part of the latest version of Continuous Performance Management, currently the data can only be output by Report Stories.(Not Support Ad Hoc/Table report)
Feedback Requests Sent Details: When viewing requests sent, users can drill down into each card to view the date and status of the request (pending, responded, or declined).

But in some cases, for example user 'One', his/her manager send him feedback successfully, which we can see under end user 'FeedbackReceived' UI. But in Story Report, this field shows blank, but not 'Pending' or other status.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

    • Analytics & Reporting (Ad Hoc, YouCalc, ORD)
      • People Analytics (Analytics Cloud for SF)
        • Data Modeling - Module & Entity Data

Reproducing the Issue

1. Creating a Story Report and select object 'Feedback' object then right join 'Feedback Request' object.
2. Preview and find data under effected user's field 'Feedback Request Status ID' shows blank.
3. Proxy as effected user, go to 'Continuous Feedback', UI shows 'Feedback received' status.

Cause

An expected behaviour of Story data source entity join.

Resolution

This is working as design and as expected.

Please make sure the effected user's request is unsolicited Feedback.
Request Status Id is not showing up in SAC Story report because its joining from Feedback --> Feedback Request entity.

In left join, all Feedbacks will be reported but Feedback Request will be reported only if they are linked to Feedback. If not, the column value will be empty. So we need a story query join like Feedback Request entity --> Feedback.

See Also

2975545 - Enhanced Feedback Experience in the Latest Version of Continuous Performance Management

Help Portal: Differences Using Legacy Version of Continuous Performance Management

Keywords

CPM, Feedback Request, Continuous Feedback, empty, unsolicited Feedback, Feedback received,  , KBA , LOD-SF-ANA-SAC-DAM , Data Modelling - Module & Entity Data Issues , LOD-SF-CPM-REP , Reporting & Analytics, Data Imports & Exports , How To

Product

SAP SuccessFactors HXM Core 2211

Attachments

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