Symptom
You want to know why wrong vaues are appearing and how to get the correct quantity in supplier invoice as per invoicing period.
Environment
SAP Business ByDesign
Reproducing the Issue
Create PO (Purchase order) with 3 items and quantity 1 each
Create GSR 1(goods and service receipt) , with Delivery date Jan 1st, item 1 for quantity 1
GSR 2 and 3, with Delivery dat feb 1st jan 1st respectively ,for item 2, quantity 1 in each
GSR 4, with delivery date feb 1st, item 3 for quantity 1
Scenario 1:
"create invoice using PO ID ,click on view all
Go to item tab you will see 3 line items where all item has quantity 1,2,1 as expected on items 1,2,3 respectively
Go to general tab and in the field Invoicing period From/To as 2023-01-01 to 2023-01-31(January),click on check
Go to item tab you will see 3 line items where quantity is 1,1,0 as expected on items 1,2,3 respectively
Now again go to general tab and change the invoicing period as 2023-02-01 to 2023-02-28( February),click on check
Go to item tab you will see 3 line items where quantity is 0,0,0 on items 1,2,3 respectively.
This is wrong we expect 0,1,1, however if you go to cost distribution of item 2, 3 you will see the GSR with quantity zero
"
or
Scenario 2:
"create invoice using PO ID, click on view all
Go to item tab you will see 3 line items where all item has quantity 1,2,1 as expected on items 1,2,3 respectively
Go to general tab and in the field Invoicing period From/To as 2023-02-01 to 2023-02-28( February),click on check
Go to item tab you will see 3 line items where quantity is 0,1,1 as expected on items 1,2,3 respectively
Now again go to general tab and change the invoicing period as 2023-01-01 to 2023-01-31(January),click on check
Go to item tab you will see 3 line items where quantity is 0,0,0 on items 1,2,3 respectively.
This is wrong we expect 1,1,0, however if you go to cost distribution of item 1, 2 you will see the GSR with quantity zero
"
The system doesn't recalculate correctly the quantities open for invoicing when the invoicing period is changed.
this means that the user has to start from scratch to enter the correct invoicing period.
Cause
Technical limitation and its known issue.
Resolution
Kindly enter final (desired) invoicing period at once and do not change it later.
or
If you happen to change or want to change then close it and recrete it with desired invoicing period.
Note:Our developers confirmed that they have added this issue to their backlog and will fix it in one of the future releases.
Keywords
KBA , SRD-SRM-SI , Supplier Invoicing , Problem