SAP Knowledge Base Article - Public

3325975 - Unable To Open Unassociated Email Due To RBAM Error

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

When trying to open an Unassociated Email via Quick View, you receive an Access Restriction error.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Center
  2. Go to Unassociated E-mail View
  3. Click on Subject Name of the E-mail

You receive Error similar to the following:
RBAM: No authorization for 'BuiltIn READ' on instance '000000000000005454545554' of 'BONodeProxy BUSINESS_ACTIVITY ROOT' in context 'UIApplication /BYD_COD/SalesOnDemand/Activities/EMail/UI/COD_EMail_QT.QT.uicomponent Operation Start' RBAM: Skip operation 'BuiltIn READ' on 'BONodeProxy BUSINESS_ACTIVITY ROOT'

Cause

This happens because the Quick Create view of the Unassociated Email loads the Email TI, this means it will only consider the Access Restrictions in place for the Email Activity BO (marked in green). If this is set as Restricted, you will not be able to open the Quick Create.

Meanwhile, you might still be able to open the Unassociated Email object (without using the Quick view), since this opens the Unassociated Emails TI, which considers a different set of Access Restriction instead (marked in red).

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Resolution

In case the restrictions must be kept, please instruct the users to direcly open the Unaossicated view (without the use of the Quick View). Otherwhise, you can set the Access Restrictions of the Emails as Unrestricted.

Keywords

Mail; Not Opening; Error; Cannot Access; Team; Employee; User; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions