SAP Knowledge Base Article - Public

3326344 - CSF Fields are not available in Compensation section after country change - Employee Central

Symptom

While performing a transfer of Legal Entity which also changes the country via Take Action, the Country/Region-Specific fields do not appear in the Compensation section. 

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to the Employee Profile of a user
  2. Click on Actions -> Select "Job Information" and "Compensation Information"
  3. Change the Legal Entity (Company) field to a value from another country
  4. See that Country Specific fields from Job Information are now displayed
  5. See that Country Specific fields from Compensation Information are not displayed automatically.

Cause

This is an expected behavior. The country will not be automatically changed for the compensation information portlet, as it is not directly linked to the legal entity. 

Resolution

Make the transfer and edit the compensation details after saving the new Job Information. The Country Specific fields will be available in the portlet after saving the Job Information.

In case this functionality important to your business, we encourage you to submit an idea for SAP SuccessFactors Products to have this functionality considered within future development cycles – you can do this on our Customer Community Portal at http://community.successfactors.com/. For detailed steps on How to Submit Ideas for SAP SuccessFactors Products, please refer to KBA 2090228.

See Also

Country/Region Specifics in Employee Central | SAP Help Portal

Keywords

CSF, compensation information, job information, CSF Fields, compInfo CSF, country specific, transfer, take action , KBA , LOD-SF-EC-CMP-UI , History or MSS UI , Product Enhancement

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions