Symptom
Perfect Store Facet does not appear for Visits generated from Route
Environment
SAP Cloud For Customer
Reproducing the Issue
Prerequisite: You have already checked 'Default Perfect Store' checkbox for the respective Visit Type 'ABC' under:
Business Configuration --> Implementation Projects --> Open Activity List --> Maintain Visit Types --> Check the 'Default Perfect Store' checkbox against Visit Type 'ABC'
Steps to Reproduce:
- Go to Visits Workcenter.
- Go to Routes Workcenter View.
- Create a Route or copy from existing Route. Set Visit Type as 'ABC'.
- Add the desired Accounts under Proposed Visits Section.
- Enter the rest of the required details.
- Activate and Generate Visits under Actions.
- Click one of the Visits from the Activity Column under Proposed Visits Section.
You see that the Perfect Store Facet is not available and Perfect Store Field is set as No.
Cause
Visits generated from Route do not set the Perfect Store flag to Checked. Hence, the Perfect Store Facet is not available.
Resolution
This is the current system behaviour.
As a workaround, you could create a rule and add the rule to default the perfect store field based on visit type.
- Go to Visit Workcenter
- Click Route Workcenter View
- Click '+' icon
- Start Adaptation
- Go to UI Component
- Go to Implementation
- Go to Rules and Validations
- Add new Rule
- Set Rule type as Value
- Add a condition where, if Visit type is 'ABC', the Perfect Store = Yes, else No
- IF(Root.VisitTypeCode=="ABC", true, false)
- Add this rule for field Perfect Store filed under 'Set Default Value'
- End Adaptation
So, when you create a new route with Visit type as 'ABC', the Perfect Store Field gets Checked automatically.
See Also
Keywords
Visit, Perfect Store Facet, Route, Not, Generated , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem