Symptom
Unable to locate the business catalogue for certain Configuration Activities/SSCUIs in sheet IMG_Act BusinessCatalog Match of the Excel file Configuration apps from the Best Practices Explorer accelerators.
Environment
SAP S/4HANA Cloud
SAP Central Business Configuration (CBC)
Reproducing the Issue
- In Project Experience click tab Configuration Activities
- Search for the Configuration activity
- Click on the entry
- Click button "Go to Activity"
- One of following message is raised: No authorization to start the UI or App could not be opened either due to an incorrect SAP Fiori launchpad configuration or a missing role assignment.
And you are unable to find the Business Catalog for that Configuration Activity in sheet IMG_Act BusinessCatalog Match of the excel file Configuration apps.
Cause
Not all business catalogs are listed under sheet IMG_Act BusinessCatalog Match of the excel file Configuration apps.
Resolution
All required SCCUI need the related business catalog SAP_CA_BC_IC_LND_XXX_PC to be added.
If a required catalog is missing under sheet IMG_Act BusinessCatalog Match of the excel file Configuration apps you can identify the business catalog using Sub Application Area of that Configuration Activity/SSCUI.
(Note : You can identify the sub application area of an Configuration Activity/SSCUI by observing column "Sub Application Area" in sheet '2302 S4H Cloud' of the same excel file)
Please follow the below steps:
- Open the Business Catalogs App
- Enter the relevant sub application area in first search box
- Enter "SAP_CA_BC_IC_LND*" in "Business Catalog ID" field
- Go to "Maintain Business Roles" app and assign all catalogs found in step 3 to BPC_EXPERT business role (or similar role you are using).
See Also
Keywords
SSCUI, Authorization, Missing authorization, CBC, Configuration Activity, Excel, Business Catalog , KBA , SD-BIL , Billing , SD-BIL-2CL , Billing (Public Cloud) , X4-CBC-SSC , Self Service Configuration , Problem