Symptom
A SMS campaign in SAP Marketing Cloud does not send the SMS to the contact, even the 'Ignore Marketing Permission' flag is set on the campaign. The contact runs into an OUTBOUND_FAILED interactions created for ID SAP_HYBRIS_MKT_IC-XXXXXXXXXXXXXXXXXXXXXXXXXXXXX.
Environment
- SAP Marketing Cloud
Reproducing the Issue
- Create and execute a SMS campaign - alternatively set the 'Ignore Marketing Permission' flag
- Observe that not all contacts receive the text message - some contacts received an OUTBOUND_FAILED interaction
Cause
On checking the interactions in detail, you observe that the OUTBOUND_FAILED interaction is created for ID SAP_HYBRIS_MKT_IC-XXXXXXXXXXXXXXXXXXXXXXXXXXXXX but not for the MOBILE ID.
On further checking you observe that the contact has a PHONE ID maintained and might even have permissions for the SMS communication medium provided.
The point is that text messages can be delivered to MOBILE numbers only - text messages won't be delivered to PHONE numbers.
Resolution
Text messages in SAP Marketing Cloud are delivered to MOBILE IDs only, therefore make sure that the contacts have a valid MOBILE ID maintained.
See Also
The marketing permission configuration 'Assign Contact ID Origin to Communication Media' allows to have both, ID origins MOBILE and PHONE mapped to the communication medium SMS - the mapping of SMS to ID origin PHONE is obsolete due to the above mentioned design. The SMS campaign itself supports the MOBILE ID only.
This scenario and configuration item are briefly mentioned at the following SAP Help document:
Keywords
sms campaign, text message campaign, text message, mobile, phone , KBA , CEC-MKT-CPG-EXE , Campaign execution , CEC-MKT-DM-PER , Marketing permissions , Problem