Symptom
An employee's Service Start Date was changed, however, the Entitlement did not change accordingly.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Time Administration Work Center.
- Go to Employees view.
- Search for the employee and click Edit button.
- Go to Time Account Balances tab.
- Select the current Time Account.
- Nothing changed in Entitlement.
Cause
This could be happening because the accrual date for the Time Account is set as the start of the year, January 1st, which means that the entitlement for this year has already been granted.
Resolution
Changing the Service Start Date will result in a corresponding change to the entitlement for the upcoming year. By following the steps below, you can verify that the entitlement has been updated for the next year:
- Go to Time Administration Work Center.
- Go to Employees view.
- Search for the employee and click Edit button.
- Go to Time Account Balances tab.
- In Time accounts panel, click Show button -> All.
You can see that the balance for the next Time Account is being displayed correctly. If you require this change to be applied for the current year, a manual adjustment can be made to the Time Account.
Keywords
Service Start Date, Balance, Entitlement, Time Account , KBA , SRD-HR-TLM , Time and Labour Management , How To