Symptom
You cannot approve service confirmation due to an error message: Action not enabled.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Managing My Area work center.
- Go to the Approvals view.
- In the Show field from drop-down select Open Tasks
- Select the Task Service Confirmation: ABC (where ABC represents the service confirmation ID) and click on the Approve button.
- An error message rasied: Action not enabled is trigger.
Cause
- Check the Time Sheet of the service performer EFG (where EFG represents the service performer ID)
- You can see no time recording maintained for the sales order.
- Open Edit Project Scope: First Implementation
- Navigate to Step 4 Questions
- You can see question "Do you want to record time for sales orders?" is checked
The question has been scoped after the creation of the service confirmation.
Since the system can't find the corresponding time recording, the service confirmation can't be approved.
Resolution
Cancel incorrect sales order and service confirmation, create new documents.
See Also
KBA 2875032 - CRM Scenario: Service - Time and Material in Sales Order
KBA 2201132 - On Clicking an Approval of the Service Confirmation, Error : "Action not enabled" is Trigger
Keywords
Approval, Action not enabled, Service Confirmation, time recording, sales order , KBA , AP-SCO , Service Confirmation Processing , Problem
Product
SAP Business ByDesign all versions