SAP Knowledge Base Article - Public

3327480 - Unable to Approve Service Confirmation

Symptom

You cannot approve service confirmation due to an error message: Action not enabled.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Managing My Area work center.
  2. Go to the Approvals view.
  3. In the Show field from drop-down select Open Tasks
  4. Select the Task Service Confirmation: ABC (where ABC represents the service confirmation ID) and click on the Approve button.
  5. An error message rasied: Action not enabled is trigger.

Cause

  1. Go to Time Administration workcenter.
  2. Select Time Sheet view.
  3. Search the Employee ID of Service performer.
  4. Check the Time Sheet of the service performer EFG (where EFG represents the service performer ID).
  5. You can see no time recording maintained for the sales order.

Now, check if the scope question "Do you want to record time for sales orders?" is checked or not.

  1. Go to Business Configuration work center.
  2. Open Edit Project Scope: First Implementation
  3. Navigate to Step 4 Questions>Sales>Selling Products and Services>Sales Orders
  4. You can see question "Do you want to record time for sales orders?" is checked

The question has been scoped after the creation of the service confirmation.

Since the system can't find the corresponding time recording, the service confirmation can't be approved.

Resolution

Cancel incorrect sales order and service confirmation, create new documents.

See Also

KBA 2875032 - CRM Scenario: Service - Time and Material in Sales Order

KBA 2201132 - On Clicking an Approval of the Service Confirmation, Error : "Action not enabled" is Trigger

Keywords

Approval, Action not enabled, Service Confirmation, time recording, sales order , KBA , AP-SCO , Service Confirmation Processing , Problem

Product

SAP Business ByDesign all versions