Symptom
External IDs are not getting updated in ID mapping table under Mapping of "ERP Accounts", only under Mapping of "Business Partners".
Environment
SAP Cloud for Customer
SAP ERP
Reproducing the Issue
1. In C4C, go to Administrator > ID Mapping for Integration
2. Check ID XXXXXXX in Mapping of Business Partners > See the external ID
2. Check ID XXXXXXX in Mapping of ERP Accounts > external ID is not visible.
Cause
After seeing both mappings in ID Mapping for Integration, you can Web Service Message Monitoring and see that the Incoming message from the ERP doesn't have a customer node in the payload.
This happens because there isn't a customer role created in the ERP.
Resolution
To solve this issue, you should create a customer role for the IDs in the ERP so the information can get to C4C and appears in the ID Mapping for Integration.
Keywords
Business Partners; ERP; ID; ID Mapping for Integration; customer role; mapping; ERP Accounts; external ID , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem
SAP Knowledge Base Article - Public