SAP Knowledge Base Article - Public

3328468 - Datasphere HANA on-premise connection error Remote source is down

Symptom

You are using Cloud Connector to connect HANA Database (on-premise) with SAP Datasphere. Getting below error when validating HANA connection in SAP Datasphere, even though HANA Database is up and running.

Connection "XXXX" is valid, but not all features are available.
- Data flows can't be used because of errors in the connection.
- Replication flows can't be used because of errors in the connection.
- Remote tables are enabled.

Data Flows: Cause: Remote source is down! Code:1
Replication Flows: Cause: Remote source is down! Code:1

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Datasphere

Reproducing the Issue

  1. Log into SAP Datasphere --> Connection
  2. Select the connection and click "Validate" button.
  3. Get the above message in symptom.

Cause

Virtual host and port are not same as internal host and port. Please note that if you are using option 'derive virtual host and port from connection details', you need to make sure that host and port details used in connection should match the virtual host and port in cloud connector.

Resolution

In the Cloud Connector, there are Virtual Host and Virtual Port as well as Internal Host and Internal Port.

If you are using option 'derive virtual host and port from connection details', please make sure that host and port details used in connection should match the virtual host and port in cloud connector.

If you are using option 'Enter Virtual Host and Port in Separate Fields', please input virtual host and port manually.

If the error still exists, check whether the log of Cloud Connector contains below:

Example A : ERROR#com.sap.core.connectivity.tunnel.client.application.ApplicationClientConnectTask#Thread-321#          #Unexpected exception while establishing application tunnel connection for tunnelId: account:///<Sub Account>/<Location ID>
io.netty.channel.ConnectTimeoutException: connection timed out: connectivitytunnel.ingress.<cluster ID>.di-br10.shoot.live.k8s-hana.ondemand.com/<IP Address>:443

Example B : DEBUG#com.sap.core.connectivity.tunnel.client.AbstractClient#Thread-114#
#Connecting to address connectivitytunnel.ingress.dis-<cluster ID>.di...k8s-hana.ondemand.com:443. No proxy is used.

Potential root causes for the timeout error are listed as below, please correct the settings accordingly:

  • In the example A, an IP address of the SAP cloud host is not added to a Firewall allow list in the on-prem network and thus the TCP connection started by the SCC cannot reach the SAP cloud host. The IP address of the SAP cloud component might have changed. We try to keep IPs stable, but this is not always possible depending on the changes during a down time.
  • In the example B, a missing or wrong configured proxy on SCC side. 
  • In case of a HEC environment, specific firewall setup for IaaS server. This template needs to be filled out and sent to HEC colleagues to allow outbound traffic:
    “Create SAP LB for OUTBOUND traffic to an EXTERNAL source”.

Check SAP Note 3330354 for more details.

See Also

Keywords

KBA , DS-DI-CON , Connections , Problem

Product

SAP Datasphere all versions

Attachments

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