SAP Knowledge Base Article - Public

3328865 - Error "validation.invalidSecurityPolicyId" On Password Change

Symptom

When you try to change your password the error "validation.invalidSecurityPolicyId" is displayed.

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Cause

The security policy was not assigned to the user.

Resolution

Ask an administrator user to assign a security policy for affected user, by following below steps.

  1. Login to the system and open settings.
  2. Under Users and Control open Users view.
  3. Open affected user.
  4. Under user details choose a security policy (for example the default security policy 'S_BUSINESS_USER')

Keywords

Security policy, Login, Password, User, Invalid , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0