SAP Knowledge Base Article - Public

3329084 - Fail to schedule publication with error "Couldn't fetch artifact from story exporter service" in SAP Analytics Cloud (SAC)

Symptom

  • Fail to schedule publication for a story in SAP Analytics Cloud (SAC).
  • After creating the publication, see following message in Calendar: Couldn't fetch artifact from story exporter service; Error: We couldn't connect to your HANACloud system.
  • The story is based on live data model and the data source is HANA Cloud.

Environment

  • SAP Analytics Cloud (Enterprise) 2023.2.5 

Reproducing the Issue

  1. Log in SAC. 
  2. Open the story and schedule a publication.
  3. After clicking 'create', see that 'Schedule created successfully'.
  4. Go to Calendar, the status is failed with message: Couldn't fetch artifact from story exporter service. Error: We couldn't connect to your HANACloud system.

 

Cause

  • The connection was converted from a direct connection with advanced features to HANA Cloud connection, this leaves some traces on the connection details.
  • These traces are causing the schedule to fail. 

Resolution

  • Deleting and recreating a new HANA Cloud connection solved the issue.

     
     

See Also

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, sap analyst cloud, HANA Cloud, HANA Cockpit , KBA , LOD-ANA-SCH , SAC Story Scheduling and Publication , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud 1.0