SAP Knowledge Base Article - Public

3329115 - Escalation flag is not enabled after Workflow conditions are met

Symptom

  • You are using a workflow to set a ticket to be escalated based on some conditions
  • Even though the conditions like Completion Date field = empty is met, the escalation flag is not enabled for the corresponding ticket

Environment

  • SAP Service Cloud
  • SAP Sales Cloud

Reproducing the Issue

  1. Create a workflow using a Timing = Schedule and where one of the conditions is Completion Date=Null (empty)
  2. Open a new ticket and meet all the conditions

Cause

  • System is working as designed
  • The "Completion Date" cannot be empty, and requires a value; if no value is entered, the system will automatically allocate one in the backend to prevent short dumps

Resolution

  • Add a comparison which is less than 01.01.0001  00:00:00 for date/time fields 
    1. Go to corresponding workflow
    2. Edit the condition to be like:
      • Field = Date Completed
      • Value Before Object Change = No
      • Compare Operator = Less than
      • With = Value
      • Date: 01.01.0001 Time = 12 AM
    3. Save the changes and retest

Keywords

Service Requests, escalated, work flow, Date Completed, /Root/ExpressionTerm/7/AttributeDescription(sap.client.data.DataField) Date Completed, Date Completed = System_administrative_data-Last_change_date_time , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2211