Symptom
A contingent worker wishes to add working hours via the app 'Manage My Timesheet'. However, Purchase Orders relevant to the user, as a service performer, do not appear in the 'My Tasks' worklist.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the app 'Manage My Timesheet'.
- The Purchase Orders are not listed to allow the user to post time.
Cause
The Service Performer cannot be assigned to more than one Supplier.
Resolution
- The assignment is made in Purchase Order and displayed in the APP Maintain Business Partner (BP) Supplier > Relationships.
- Remove any additional assignments in Purchase Order so the user is only assigned to one Supplier.
Note: If two suppliers for a user were required, it would be possible to create a second user ID for the service performer (with a different email address) so that the second user could be assigned to a second Supplier.
Keywords
i_serviceperformertosuplr, CL_CATS_COMMON_REUSE, CL_HCM_CATS_MAN_V1_REUSE, GET_PO_DETAILS_BY_SERV_PERF, Supplier PERNR, service performer, purchase order, contingent worker, working hours, my tasks , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , MM-PUR-PO , Purchase Orders , MM-FIO-PUR-PO , Fiori UI for Purchase Orders , MM-PUR-SVC-SES , Service Entry Sheet for Service Procurement , MM-FIO-SRV , Fiori UI for Services Management , Problem