SAP Knowledge Base Article - Public

3329986 - Leave does not Appear in Track My Leave Requests

Symptom

A leave time entry was created for a user, however the user is not able to see the leave request in Self-Services Leave Request tracking.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Home work center.
  2. Navigate to the Self-Services (or Self-Services Overview) view.
  3. Under the section Time, click on Track My Leave Requests.

Here the user is not able to see the leave entry that was created.

Cause

There are 3 possible scenarios for the creation of a leave request, which cause different behaviors on the visibility of the request in the Self-Services page:

  • If the request was created by the user themselves, it will appear in the leave request tracking in Self-Services.
  • If the request was created by another user through the Time Administration work center and activated, it will not appear in Self-Services.
  • If the request was created by another user through the Time Administration work center and sent to approval (via Actions -> Submit to Approval), the leave request will also appear in the Self-Services page.

Resolution

The system works as expected

Keywords

Holiday, Vacation, Recording , KBA , SRD-HR-TLM , Time and Labour Management , How To

Product

SAP Business ByDesign all versions