Symptom
- Links in Custom Cards and Custom Quick Actions function properly in the web browser, but they fail to open in the Mobile App.
- Popover is selected a the Target behavior in Navigation section
- Some content isn't available on mobile. Please try viewing it on desktop.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Mobile Application
Reproducing the Issue
- Create a Custom Card or Custom Quick Action and select Popover as the Target option.
- Add URLs in the Content of Navigation section.
- Save changes to the Custom Card or Quick Action.
- Open the in a desktop browser to verify that the link works.
- Open the mobile app and try to access the custom card or custom quick action and notice that the link does not open.
- You will received a message stating, 'Some content isn't available on mobile. Please try viewing it on desktop.'
Cause
- Some web links may not work in the mobile app.
- Soft links in custom cards, such as any links that are not fully qualified URLs and do not begin with HTTP or HTTPS, are not supported.
- Links work differently on the mobile app, which brings unique risks compared to the desktop version. On desktop, all links open in the same session within the web app. However, on mobile, external links open in a separate browser, and soft links won't be recognized by that browser.
- The Popover target was not built to support embedded links.
Resolution
A disclaimer can be seen when creating the custom card and custom quick action in the Navigation section: 'Links may not function in the mobile app. You may want to hide the quick action.' Please refer to the screenshot above.
In the Navigation section for Custom Card and Custom Quick Actions, you can set the Target to a URL that will connect to the external sites.
To proceed, kindly follow the steps listed below:
- Access Manage Home Page.
- Go to the section where you can create Custom Cards or Quick Actions.
- Fill in general information and complete all required fields.
- In the Navigation section, choose the URL as the Target for your Custom Card or Quick Action and add the URL. (For reference, please see screenshot above)
- Fill out any additional information needed and finalize the creation process for your Custom Card or Quick Action.
However, if you select the URL as the target and the links still don’t function in the mobile app. As a home page administrator, you have the option to hide it in the mobile app.
A Show card in mobile app or Show mobile action in mobile app setting is available in several places, wherever you can configure custom content containing a web link. It's on by default, but if you turn it off, the card or quick action is hidden in the mobile app.
See Also
Keywords
custom card, custom quick action, URL, links, mobile app, link doesn't work on mobile, Some content isn't available on mobile. Please try viewing it on desktop, expected behavior, Links may not function in the mobile app. You may want to hide the quick action, Show card in mobile app, Show mobile action in mobile app, Navigation, Popover, Target Popover, Target URL , KBA , LOD-SF-PLT-MOB , Mobile Issues , Problem