SAP Knowledge Base Article - Public

3330992 - In Mashup Preview You Face Error "This Content Is Blocked"

Symptom

While creating a mashup, when you click on preview, you receive the message: "This content is blocked. Contact the site owner to fix the issue.".

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Click on the profile button and go to Settings.
  2. Go to All settings and enter Mashup Authoring view.
  3. Click on create button and fill mandatory data.
  4. In the URL field, paste your URL (e.g. https://www.test.com/)
  5. Click on preview.
  6. Result: You will see the error: This content is blocked. Contact the site owner to fix the issue.

Cause

A. The Mashup URL or the authentication application URL were not added to the trusted domain list. 

B. In case the URL has port information, this was not added to Content Security Policy.

C. You have added the URL to the trusted domain list, but you have not refreshed the browser, so the setting is updated.

Resolution

A. Add the mashup URL and the authentication URL. For example, if you have a mashup that uses okta for authentication, then *.okta.com should be added to Content Security Policy.

  1. Go to All settings and open Content Security Policy screen.
  2. In the Frame Source section, click on +.
  3. Add the mashup URL (e.g *.test.com) and the authentication URL (e.g *.okta.com)
  4. Click on the check icon.

B. In case your URL has port information, please follow below steps:

  1. Go to All settings and open Content Security Policy screen.
  2. In the Frame Source section, remove the existing affected URL, in case it was added before.
  3. In the Frame Source section, click on +.
  4. Add the mashup URL with the port information like this (e.g *.test.com:12345) in which 12345 represents the port number.
  5. Click on the check icon.
  6. After adding it, please log off and login again to test.

In case the issue persists after following above steps, please do the same steps for all the sections in Content Security Policy, as there are some other sources that can get blocked depending on the application.

C. Once you add the URL to the trusted domain list, it will not be registered until a browser reload is done. If you try to create a mashup immediately after adding the URL, you will still get the same error. So please refresh the browser and then create/edit the mashup. It should work as expected then.

See Also

Help Portal: Mashups

Keywords

Content, Blocked, HTML Mashup, URL, Iframe, Frame, CSP, Content Security Policy, Trusted domain , KBA , CEC-CRM-MAS , Mashups for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

image.png