SAP Knowledge Base Article - Public

3331372 - Error creating Service Entry Sheets from timesheet entries

Symptom

As a contingent worker or a line manager you post working hours against a purchase order using the APP 'Manage My Timesheet' or 'Notify Missing Times' respectively. 
You expect the system to automatically generate a service entry sheet but when you check the job log via the APP 'Monitor Service Entry Sheet Generation Log' you find unexpected errors like MM_PUR_SES042 or MM_PUR_SES057.

Environment

SAP S/4Hana Cloud - All Versions 

Reproducing the Issue

1) Post your working hours via APP 'Manage My Timesheet'
2) Check the the APP 'Monitor Service Entry Sheet Generation Log' Errors such as these below are found in the job log  
'Product group XX differs from the product group of the PO item XX' (MM_PUR_SES042)
'The service XX differs from the service of the purchase order item XX' (MM_PUR_SES057). 

Cause

Unauthorised user or master data issue.

When the system tries to generate a service entry sheet from a timesheet it tries to copy the purchase order item data over to the service entry sheet. 
In the copy, the system checks the authorisation of the user, the 'GR based IV' flag is set on the PO item and that the deletion indicator is not set. If 
all these are valid then the PO item data is transferred to the new SES item. If there is a failure not all of the PO item will be transferred leading to such errors.  

Resolution

1) Check the user has full authorisation for the Company code, Purchase Organisation, Purchasing group and plant in the reference purchase order. 
2) Check the reference purchase order item is not marked for deletion 
3) Check the reference purchase order item has the GR based IV flag set 

See Also

2686576

Keywords

WEBRE, CL_DET_SES_ITEM_COPY_FROM_PO, MM_SES_EKO, MM_PUR_SES042, MM_PUR_SES057 , KBA , MM-PUR-SVC-SES , Service Entry Sheet for Service Procurement , Problem

Product

SAP S/4HANA Cloud 2302