Symptom
While updating the manager for user in Employee Central the system shows a pop-up message when saving with the error "Get personID is null"
Environment
SAP SuccessFactors Performance Management
SAP SuccessFactors Employee Central
Reproducing the Issue
- Form has a route map with future steps associated to manager "X"
- Manager "X" is terminated in Employee Central
- DRTM to purge inactive user(soft-purge)
- Job information > Update the manager for the affected subject and click save
- Pop-up error message "userid="X"get personId is null "
Cause
This scenario happens due to the order of the actions performed, the forms should always be transferred to new manager before terminating the current/previous manager. Terminating the manager before transferring the forms to the new manager can get the forms stuck, and in this scenario where a purge is performed, there will be no association with the purged manager userID, therefore this can corrupt the process.
Resolution
Forms should be transferred to the new managers before terminating the current/previous manager to avoid the form getting stuck/corrupted.
Our Development team is evaluating a guardrail to prevent the forms from getting stuck, however, this is still under analysis for future development.
See Also
Keywords
manager transfer, future date, purge, purged user, personId is null, job relationship, job information, PMU-19860 , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , LOD-SF-EC-JRL , Job Relationships , Product Enhancement