SAP Knowledge Base Article - Public

3331988 - Get personID is null - Manager Transfer - Performance Management

Symptom

While updating the manager for user in Employee Central the system shows a pop-up message when saving with the error "Get personID is null"

Environment

SAP SuccessFactors Performance Management

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Form has a route map with future steps associated to manager "X"
  2. Manager "X" is terminated in Employee Central
  3. DRTM to purge inactive user(soft-purge)
  4. Job information > Update the manager for the affected subject and click save
  5. Pop-up error message "userid="X"get personId is null "

Cause

This scenario happens due to the order of the actions performed, the forms should always be transferred to new manager before terminating the current/previous manager. Terminating the manager before transferring the forms to the new manager can get the forms stuck, and in this scenario where a purge is performed, there will be no association with the purged manager userID, therefore this can corrupt the process.

Resolution

Forms should be transferred to the new managers before terminating the current/previous manager to avoid the form getting stuck/corrupted.

Our Development team is evaluating a guardrail to prevent the forms from getting stuck, however, this is still under analysis for future development.

See Also

2144428 - Top 10 reasons Forms Are Not Transferring to New Manager or Failed to Route to Manager - Performance Management

2078831 - Troubleshooting Document Transfer Options - Performance Management

Keywords

manager transfer, future date, purge, purged user, personId is null, job relationship, job information, PMU-19860 , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , LOD-SF-EC-JRL , Job Relationships , Product Enhancement

Product

SAP SuccessFactors Performance & Goals all versions