SAP Knowledge Base Article - Public

3332477 - When previewing data of a Custom Analytical Query, it's showing "#" as a value in some columns - SAP S/4HANA Cloud Public Edition

Symptom

When previewing data of a Custom Analytical Query, it's showing "#" as a value in some columns.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to Custom Analytical Query app.
  2. Open and preview the Query.
  3. Some fields contains "#" as a value.

Cause

The "#" symbol in some fields of the Custom Analytical Query report is due those fields not being populated in the Custom CDS View. 

Resolution

It could be found that there are empty fields in some columns, when opening Custom CDS Views application and previewing the underlying Custom CDS View of the query.

These empty fields are being reflected to the Custom Analytical Query. 

Note: 

  1. The Custom Analytical Query tool does not currently provide the functionality to display a blank space in place of the '#' indicator.
  2. If the specific field is not required for your reporting needs, deselect it from the query.

Keywords

custom analytical query, #, preview data, empty , KBA , BC-SRV-APS-EXT-AQD , Fiori based Query Designer , Problem

Product

SAP S/4HANA Cloud Public Edition all versions