SAP Knowledge Base Article - Public

3332719 - Performance issue can be observed in Calendar menu in SAP Analytics Cloud (SAC)

Symptom

When opening the Calendar menu in SAP Analytics Cloud slowness can be experienced.

Environment

SAP Analytics Cloud (Enterprise) 2023.2.11

Reproducing the Issue

In SAP Analytics Cloud (SAC):

  1. Log in to SAC tenant
  2. Navigate to Calendar menu
  3. Observe the general slowness of loading of the Calendar item

Please note if you do not see any Calendar items, make sure to use the "Activate Admin Mode".

Cause

  • A lot of calendar tasks are loaded and rendered.
  • A data locking task series which occurs every few minutes, where every single task runs for months.

Resolution

Make sure on your side that you load less tasks.

This can be done by:

  • deleting the old series completely (if you only delete future occurrences, you will still see some issues for the next month)
  • when creating a series, set a reasonable due date (data actions never run more than 24 hours maximum, most times they only run less than some minutes)
  • only use minute recurrence when absolutely needed

Also please notice the difference between DUE DATE (of a single occurrence/task) and END DATE (the end date of the entire series, no occurrences after this date).

See Also

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Keywords

Calendar, SAC, SAP, Items, Performance, Slowness, Freezing, Load time, Respond, Admin mode , KBA , LOD-ANA-PL-PRO , Planning Process, Input Task, Calendar Task , Problem

Product

SAP Analytics Cloud 1.0